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<Project/Sub-project Title> Test Plan
Introduction

1.1 Purpose

The purpose of the Test Plan for the <Project/Sub-project Title> is to:

· Provide a central artifact to govern the strategic approach of the test effort; it defines the general approach to be employed when testing the software and when evaluating the results of that testing. Planning artifacts will refer to the test strategy regarding the governing of detailed testing work.

· Provide visible confirmation to test-effort stakeholders that adequate consideration has been given to the governing the test effort and, where appropriate, to have those stakeholders approve the strategy.

This Master Test Plan also supports the following specific objectives: 

· Identifies items that should be targeted by the tests.

· Identifies the motivation for and ideas behind the test areas to be covered.

· Outlines the testing approach that will be used.

· Identifies the required resources and provides an estimate of the test efforts.

· Lists the deliverable elements of the test project.
1.2 Scope
This Test Plan will cover the following testing activities as identified in the testing strategy:

[Include the sections below that will be in scope for testing your specific project.  Unit Test, Integration Test, and User Acceptance will be required.]
· Unit Test

· Integration Test

· User Acceptance Test

· Load Test

· Operational Readiness Test

· Beta Test

1.3 Project Context and Background

[Provide a brief description of the background surrounding the project with specific reference or focus on important implications for the test effort. Include information such as the key problem being solved, the major benefits of the solution, the planned architecture of the solution, and a brief history of the project. Note that where this information is defined sufficiently in other documents, you might simply include a reference to those other documents if appropriate; however, it may save readers of this document time and effort if a limited amount of information is duplicated here: so you should use your judgment. As a general rule, this section should only be about three to five paragraphs in length.]

2. Test Items

The items below identify the test items(software, hardware, and supporting product elements(that have been identified and excluded as targets for testing. This represents what items will and will not be tested. 

[Provide an overview narrative describing the purpose and scope of the test for each testing phase and a list of the major target test items.  

 The item list should include items produced directly by the project development team and items that those products rely on; for example, basic processor hardware, peripheral devices, operating systems, third-party products or components, etc. This may simply be a list of the categories or target areas. If a specific item will not be tested, indicate the justification, such as:

· “These tests do not help achieve the evaluation mission.” 

· “There are insufficient resources to conduct these tests.” 

· “These tests are unnecessary due to the testing conducted by ADPO.”  - i.e. for CBS, EAS, ect.

Include the sections below that will be in scope for testing your specific project.  Unit Test, Integration Test, and User Acceptance will be required.]
2.1.1 Unit Test

2.1.1.1 Overview

[Provide overview narrative here]

2.1.1.2 Items Tested
[List unit test items here]
2.1.1.3 Items Not Tested

[List unit test items here]

2.1.2 Integration Test

2.1.2.1 Overview

[Provide overview narrative here]

2.1.2.2 Items Tested
[List integration test items here]
2.1.2.3 Items Not Tested
[List integration test items here]

2.1.3 User Acceptance Test

2.1.3.1 Overview

[Provide overview narrative here]

2.1.3.2 Items Tested
[List user acceptance test items here]
2.1.3.3 Items Not Tested
[List user acceptance test items here]
2.1.4 Load Test

2.1.4.1 Overview

[Provide overview narrative here]

2.1.4.2 Items Tested

[List load test items here]

Items Not Tested

[List load test items here]

2.1.5 Operational Readiness Test

2.1.5.1 Overview

[Provide overview narrative here]

2.1.5.2 Items Tested

[List operational readiness test items here]

2.1.5.3 Items Not Tested

[List operational readiness test items here]

2.1.6 Beta Test

2.1.6.1 Overview

[Provide overview narrative here.  For Beta testing, make sure to include the beta testing area and the criteria for selecting it.]

2.1.6.2 Items Tested

[List beta test items here]

2.1.6.3 Items Not Tested

[List beta test items here]
3. Test Execution Procedures
[Include the sections below that will be in scope for testing your specific project.  Unit Test, Integration Test, and User Acceptance will be required.]

3.1 Unit Test
3.1.1 Unit Test Entry Criteria

The criteria that determine when unit testing can begin include the following:

· Completed Unit Code

· Completed Unit Test Script

3.1.2 Unit Test Plan Exit Criteria

The criteria that determine when the unit testing is complete, or that continued execution provides no further benefit, include the following:
· Completed Peer Code Review

· Successful execution of the Unit Test Script

· No issues of any severity remaining from unit testing unless the issue is determined to be low impact, low risk.  To be reviewed with Project Manager, Test Manager and Software Architect for acceptable resolution.
3.1.3  Suspension and Resumption Criteria

No special criteria for suspension and resumption of unit testing are required.  The unit tester will use their best judgments to determine if coding changes are needed before testing can be completed.   The tester should keep in mind that the entire unit test script must be completed with one version of the code. 
3.2 Integration Test

3.2.1 Integration Test Entry Criteria

The criteria that determine when integration testing can begin include the following:

· No critical or major severity issues remaining from unit testing

· Completed Integration Test Scripts

· Correct version of software is moved into the integration testing environment
3.2.2 Integration Test Plan Exit Criteria

The criteria that determine when the integration testing is complete, or that continued execution provides no further benefit, include the following:

· Successful execution of Integration Test Scripts

· No open critical, major or average severity issues unless the issue is determined to be low impact, low risk.  To be reviewed with Project Manager, Test Manager and Software Architect for acceptable resolution.
3.2.3  Suspension and Resumption Criteria

When a defect is detected during Integration Testing, testing should halt and the tester should log the defect in a Change Request form.  The tester should then give the form the Test Analyst for review and determination of error and severity.  If the defect is not critical or major severity then testing may continue.
To resume a suspended test, the defects must be corrected and the software promoted to the testing environment.  This shall be reflected on the change request form.  Initialization steps may be required to resume the test script depending on where the defect occurred.
3.3 User Acceptance Test

3.3.1 User Acceptance Test Entry Criteria

The criteria that determine when user acceptance testing can begin include the following:

· No critical or major severity issues remaining from unit testing

· Completed User Acceptance Test Scripts

· Correct version of software is moved into the user acceptance testing environment
3.3.2 User Acceptance Test Plan Exit Criteria

The criteria that determine when the user acceptance testing is complete, or that continued execution provides no further benefit, include the following:

· Successful execution of User Acceptance Test Scripts

· No open critical, major or average severity issues unless the issue is determined to be low impact, low risk.  To be reviewed with Project Manager, Test Manager and Software Architect for acceptable resolution.
3.3.3  Suspension and Resumption Criteria

When a defect is detected during User Acceptance Testing, testing should halt and the tester should log the defect in a Change Request form.  The tester should then give the form the Test Analyst for review and determination of error and severity.  If the defect is not critical or major severity then testing may continue.

To resume a suspended test, the defects must be corrected and the software promoted to the testing environment.  This shall be reflected on the change request form.  Initialization steps may be required to resume the test script depending on where the defect occurred.

3.4 Load Test

3.4.1 Load Test Entry Criteria

The criteria that determine when load testing can begin include the following:

· No critical or major severity issues remaining from unit testing

· Completed Integration Test Scripts

· Correct version of software is moved into the load testing environment

3.4.2 Load Test Plan Exit Criteria

The criteria that determine when the load testing is complete, or that continued execution provides no further benefit, include the following:

· Successful execution of Load Test Scripts

· No open critical, major or average severity issues unless the issue is determined to be low impact, low risk.  To be reviewed with Project Manager, Test Manager and Software Architect for acceptable resolution.

3.4.3  Suspension and Resumption Criteria

When a defect is detected during Load Testing, testing should halt and the tester should log the defect in a Change Request form.  The tester should then give the form the Test Analyst for review and determination of error and severity.  If the defect is not critical or major severity then testing may continue.
To resume a suspended test, the defects must be corrected and the software promoted to the testing environment.  This shall be reflected on the change request form.  Initialization steps may be required to resume the test script depending on where the defect occurred.

3.5 Operational Readiness Test

3.5.1 Operational Readiness Test Entry Criteria

The criteria that determine when operational readiness testing can begin include the following:

· No critical or major severity issues remaining from any testing

· Completed Operational Readiness Test Scripts

· Correct version of software is moved into the production environment

3.5.2 Operational Readiness Test Plan Exit Criteria

The criteria that determine when the operational readiness testing is complete, or that continued execution provides no further benefit, include the following:

· Successful execution of Operational Readiness Test Scripts

· No open critical, major or average severity issues unless the issue is determined to be low impact, low risk.  To be reviewed with Project Manager, Test Manager and Software Architect for acceptable resolution.

3.5.3  Suspension and Resumption Criteria

When a defect is detected during Operational Readiness Testing, testing should halt and the tester should log the defect in a Change Request form.  The tester should then give the form the Test Analyst for review and determination of error and severity.  If the defect is not critical or major severity then testing may continue.

To resume a suspended test, the defects must be corrected and the software promoted to the testing environment.  This shall be reflected on the change request form.  Initialization steps may be required to resume the test script depending on where the defect occurred.

3.6 Beta Test

3.6.1 Beta Test Entry Criteria

The criteria that determine when beta testing can begin include the following:

· [Specify the criteria that will be used to determine where the execution of beta testing can begin]
3.6.2 Beta Test Plan Exit Criteria

The criteria that determine when the beta testing is complete, or that continued execution provides no further benefit, include the following:

· [Specify the criteria that will be used to determine where the execution of beta testing is complete or that continued testing provides no further benefit.]
3.6.3  Suspension and Resumption Criteria

[Specify the criteria that will be used to determine whether testing should be prematurely suspended or ended before the plan has been completely executed, and under what criteria testing can be resumed.]
4. Test Deliverables

[In this section, list the various artifacts that will be created by the test effort that are useful deliverables to the various stakeholders of the test effort. Don’t list all work products; only list those work products that give direct, tangible benefit to a stakeholder and those by which you want the success of the test effort to be measured.]
The deliverables for all testing phases is the completed test cases, test scripts and test logs along with any change requests due to defects.  Any additional information validating the results of test scripts should be attached to the testing documentation, such as table printouts for data, replication testing or screenshots of web pages.  Once all testing documents have been completed, the application can be deemed ready for production use.

5. Test Data Management
[In this section, identify how testing data will be managed for each testing phase.  Identify any procedures to initialize, load, or reload data.  
If necessary break this information up into multiple sections, i.e. load testing may not require the same data management as integration testing would.]
6. Test Schedule 

[Identify the key schedule milestones that set the context for the testing effort. Avoid repeating too much detail that is documented elsewhere in plans that address the entire project.] 
Table 1: Milestones
	Milestone
	Planned

Start Date
	Planned

End Date
	Estimated

Effort

	
	
	
	

	
	
	
	

	
	
	
	

	
	
	
	

	
	
	
	


7. Test Environment

[Include the sections below that will be in scope for testing your specific project.  Unit Test, Integration Test, and User Acceptance will be required.  Customize as necessary.]

7.1 Unit Test
	
	Workstations
	Application Server
	Mainframe
	Mail Server
	Database Server

	Name
	
	
	
	
	

	Software
	
	
	
	
	

	Physical Location
	
	
	
	
	

	IP Address
	
	
	
	
	

	URL/Database
	
	
	
	
	


7.2 Integration Test
	
	Workstations
	Application Server
	Mainframe
	Mail Server
	Database Server

	Name
	
	
	
	
	

	Software
	
	
	
	
	

	Physical Location
	
	
	
	
	

	IP Address
	
	
	
	
	

	URL/Database
	
	
	
	
	


7.3 User Acceptance Test
	
	Workstations
	Application Server
	Mainframe
	Mail Server
	Database Server

	Name
	
	
	
	
	

	Software
	
	
	
	
	

	Physical Location
	
	
	
	
	

	IP Address
	
	
	
	
	

	URL/Database
	
	
	
	
	


7.4 Load Test
	
	Workstations
	Application Server
	Mainframe
	Mail Server
	Database Server

	Name
	
	
	
	
	

	Software
	
	
	
	
	

	Physical Location
	
	
	
	
	

	IP Address
	
	
	
	
	

	URL/Database
	
	
	
	
	


7.5 Operational Readiness Test
	
	Workstations
	Application Server
	Mainframe
	Mail Server
	Database Server

	Name
	
	
	
	
	

	Software
	
	
	
	
	

	Physical Location
	
	
	
	
	

	IP Address
	
	
	
	
	

	URL/Database
	
	
	
	
	


7.6 Beta Test
	
	Workstations
	Application Server
	Mainframe
	Mail Server
	Database Server

	Name
	
	
	
	
	

	Software
	
	
	
	
	

	Physical Location
	
	
	
	
	

	IP Address
	
	
	
	
	

	URL/Database
	
	
	
	
	


Revision History

	Version
	Date
	Summary of Changes
	Author
	Revision Marks
(Yes/No)

	0.1
	
	Initial revision.
	
	

	
	
	
	
	

	
	
	
	
	


[Note: This template is provided to assist authors with the FSA SDLC.

· Blue or black text within arrow brackets (< >) should be customized before publishing this document. Be sure to change the color of the text to black before publishing this document.

· Blue text within square brackets ([ ]) provides instructions and guidance and should be deleted before publishing this document.

This document uses automatic fields:

· Viewing Automatic Fields
If you cannot see the automatic fields in this document, select Tools>Options, and then choose the View tab; in the Field Shading drop-down list, choose Always.

· Customizing Automatic Fields
To customize the automatic fields in this document, select File>Properties and then replace the information in brackets (< >) with the appropriate information for this document; be sure to also customize the Custom properties by choosing the Custom tab, selecting a property, changing its value, and then clicking Modify. Repeat this for each custom field. Click OK to close the dialog.

· Updating Automatic Fields
You can update the automatic fields with new, customized information by selecting Edit>Select All (or Ctrl+A) and then pressing F9, or by simply clicking on a field and pressing F9. This must be done separately for Headers and Footers (View>Header and Footer, Ctrl+A, F9). See MS Word help for more information on working with fields.]
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